linux强制卸载PHP时出现的问题及解决方案过程
2014-10-11 14:14:31   来源:   评论:0 点击:

强制卸载PHP时出现的问题及解决方案过程如下:
强制卸载PHP时出现的问题及解决方案过程
[root@localhost ~]# php -v
PHP 5.3.3 (cli) (built: Dec 11 2013 03:29:57) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
[root@localhost ~]# rpm -qa|grep php
php-gd-5.3.3-27.el6_5.x86_64
php-mbstring-5.3.3-27.el6_5.x86_64
php-common-5.3.3-27.el6_5.x86_64
php-mysql-5.3.3-27.el6_5.x86_64
php-pear-1.9.4-4.el6.noarch
php-xml-5.3.3-27.el6_5.x86_64
php-xmlrpc-5.3.3-27.el6_5.x86_64
php-pdo-5.3.3-27.el6_5.x86_64
php-cli-5.3.3-27.el6_5.x86_64
php-ldap-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-mysql-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-pdo-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-xml-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-cli-5.3.3-27.el6_5.x86_64
error: Failed dependencies:
php-cli >= 5.1.0-1 is needed by (installed) php-pear-1:1.9.4-4.el6.noarch
[root@localhost ~]# rpm -e php-cli-5.3.3-27.el6_5.x86_64
error: Failed dependencies:
 php-cli >= 5.1.0-1 is needed by (installed) php-pear-1:1.9.4-4.el6.noarch
[root@localhost ~]# rpm -e php-gd-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-common-5.3.3-27.el6_5.x86_64
error: Failed dependencies:
php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-cli-5.3.3-27.el6_5.x86_64
php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-ldap-5.3.3-27.el6_5.x86_64
php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-xmlrpc-5.3.3-27.el6_5.x86_64
php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-mbstring-5.3.3-27.el6_5.x86_64
[root@localhost ~]# php -v
PHP 5.3.3 (cli) (built: Dec 11 2013 03:29:57) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
[root@localhost ~]# rpm -qa|grep php
php-mbstring-5.3.3-27.el6_5.x86_64
php-common-5.3.3-27.el6_5.x86_64
php-pear-1.9.4-4.el6.noarch
php-xmlrpc-5.3.3-27.el6_5.x86_64
php-cli-5.3.3-27.el6_5.x86_64
php-ldap-5.3.3-27.el6_5.x86_64
[root@localhost ~]# yum remove php
Loaded plugins: fastestmirror
Setting up Remove Process
No Match for argument: php
Loading mirror speeds from cached hostfile
 * base: centos.ustc.edu.cn
 * extras: centos.ustc.edu.cn
 * updates: centos.ustc.edu.cn
base                                                                                                                                | 3.7 kB     00:00     
extras                                                                                                                              | 3.4 kB     00:00     
updates                                                                                                                             | 3.4 kB     00:00     
Package(s) php available, but not installed.
No Packages marked for removal
[root@localhost ~]# php -v
PHP 5.3.3 (cli) (built: Dec 11 2013 03:29:57) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
[root@localhost ~]# rpm -qa|grep php
php-mbstring-5.3.3-27.el6_5.x86_64
php-common-5.3.3-27.el6_5.x86_64
php-pear-1.9.4-4.el6.noarch
php-xmlrpc-5.3.3-27.el6_5.x86_64
php-cli-5.3.3-27.el6_5.x86_64
php-ldap-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-cli-5.3.3-27.el6_5.x86_64
error: Failed dependencies:
        php-cli >= 5.1.0-1 is needed by (installed) php-pear-1:1.9.4-4.el6.noarch
[root@localhost ~]# rpm -e php-mbstring-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-common-5.3.3-27.el6_5.x86_64
error: Failed dependencies:
        php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-cli-5.3.3-27.el6_5.x86_64
        php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-ldap-5.3.3-27.el6_5.x86_64
        php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-xmlrpc-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-pear-1.9.4-4.el6.noarch
[root@localhost ~]# rpm -e php-xmlrpc-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-ldap-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-common-5.3.3-27.el6_5.x86_64
error: Failed dependencies:
        php-common(x86-64) = 5.3.3-27.el6_5 is needed by (installed) php-cli-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-cli-5.3.3-27.el6_5.x86_64
[root@localhost ~]# rpm -e php-common-5.3.3-27.el6_5.x86_64
[root@localhost ~]# php -v
-bash: /usr/bin/php: 没有那个文件或目录
[root@localhost ~]# 

相关热词搜索:linux

上一篇:linux centOS怎样强制卸载PHP
下一篇:解决apache启动错误"httpd:Could not reliably determine..."